Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-687

[Ruby]Cannot install ruby driver on Windows if we haven't installed CUBRID first

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Not a Bug
    • Affects Version/s: None
    • Fix Version/s: Ruby 8.4.4.0002
    • Component/s: Ruby Driver
    • Labels:
    • Environment:
      • OS: Win7
      • CUBRID: 8.4.4.0227
      • Ruby: 1.8.7
      • Driver: 8.4.4.0002 (2013-10-21)

      Description

      • Brief: Cannot install ruby driver 8.4.4.0002 on Windows if we haven't installed CUBRID first
      • Test Code
        D:\QA Project\Ruby Driver\cubrid_ruby_build\RB-8.4.4\2013_10_21>gem install cubrid-8.4.4.0002.gem
        Building native extensions.  This could take a while...
        ERROR:  Error installing cubrid-8.4.4.0002.gem:
                ERROR: Failed to build gem native extension.
        
                C:/Ruby187/bin/ruby.exe extconf.rb
        checking for cci_init() in -lcascci... no
        *** extconf.rb failed ***
        Could not create Makefile due to some reason, probably lack of
        necessary libraries and/or headers.  Check the mkmf.log file for more
        details.  You may need configuration options.
        
        Provided configuration options:
                --with-opt-dir
                --without-opt-dir
                --with-opt-include
                --without-opt-include=${opt-dir}/include
                --with-opt-lib
                --without-opt-lib=${opt-dir}/lib
                --with-make-prog
                --without-make-prog
                --srcdir=.
                --curdir
                --ruby=C:/Ruby187/bin/ruby
                --with-casccilib
                --without-casccilib
        cascci could not be found.
        Please check if CUBRID database is installed and if the $CUBRID environment variable is correctly set to the location where cubrid is installed.
        
        
        Gem files will remain installed in C:/Ruby187/lib/ruby/gems/1.8/gems/cubrid-8.4.4.0002 for inspection.
        Results logged to C:/Ruby187/lib/ruby/gems/1.8/gems/cubrid-8.4.4.0002/ext/gem_make.out
        

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            cn15800 谢韦华[Bert]
            Reporter:
            ryin005 Ray Yin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: