Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-625

[Perl][Manual] bind_param_array() and execute_array() haven't been introduced in the manual

    Details

    • Type: Improvement
    • Status: Reopened
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: Perl 9.2.0.0002
    • Component/s: Perl Driver
    • Labels:
    • Environment:
      • OS: Linux 64bit Win 32bit
      • CUBRID: 9.2.0
      • Perl: v5.18.0
      • Driver: cubrid-perl 9.2.0.0001 (20130726)

      Description

      It seems like the bind_param_array() and execute_array() functions are still supported by our perl driver 9.2.0, but currently we can not find any information about them in the driver's manual http://search.cpan.org/~cubrid/DBD-cubrid-9.1.0.0001/cubrid.pm

      So for the incomming 9.2.0 version, I suggest to add some introductions about these two functions to 'Statement Handle Methods' section in the manual

      Usage:

      {code}
      #!perl -w
      use DBI;
      use Test::More;
      use strict;

      my $dsn="dbi:cubrid:database=demodb;host=localhost;port=33000";
      my $dbh=DBI->connect($dsn, "dba", "");

      $dbh->do("DROP TABLE IF EXISTS test_cubrid");
      $dbh->do("CREATE TABLE test_cubrid (id VARCHAR)");

      my $sth = $dbh->prepare ("INSERT INTO test_cubrid VALUES ");
      $sth->bind_param_array (1, ['aaa', 'bbb']);
      $sth->execute_array( { ArrayTupleStatus => \my @tuple_status } );{code}

        Activity

        Hide
        cn15800 谢韦华[Bert] added a comment -

        fixed

        Show
        cn15800 谢韦华[Bert] added a comment - fixed
        Hide
        ryin005 Ray Yin added a comment -

        I still cannot find any information about bind_param_array() and execute_array() on the manual e.g. http://search.cpan.org/~cubrid/DBD-cubrid-9.1.0.0001/cubrid.pm

        reopen the issue

        Show
        ryin005 Ray Yin added a comment - I still cannot find any information about bind_param_array() and execute_array() on the manual e.g. http://search.cpan.org/~cubrid/DBD-cubrid-9.1.0.0001/cubrid.pm reopen the issue
        Hide
        cn15800 谢韦华[Bert] added a comment -

        This issue will be fix in 9.2.0.0002 and 8.4.4.0002, not fix in 9.1.0.0001.

        The help doc of perl will be compile in DBD-Cubrid-9.2.0.0002.tar.gz, we could not fix document only.

        It is different with php.

        When you unpack DBD-Cubrid-9.2.0.0002.tar.gz, you can find a file: cubrid.pm, this is help document.

        Show
        cn15800 谢韦华[Bert] added a comment - This issue will be fix in 9.2.0.0002 and 8.4.4.0002, not fix in 9.1.0.0001. The help doc of perl will be compile in DBD-Cubrid-9.2.0.0002.tar.gz, we could not fix document only. It is different with php. When you unpack DBD-Cubrid-9.2.0.0002.tar.gz, you can find a file: cubrid.pm, this is help document.

          People

          • Assignee:
            cn15800 谢韦华[Bert]
            Reporter:
            ryin005 Ray Yin
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: